Antworten

SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Maddeen
Tiertrainer
Posts: 15
Post 1 von 16
9.477 Ansichten

SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Hi zusammen,

 

ich hoffe hier liest entweder ein Sky-Techniker mit oder es gibt hier Leute, die sich mit Netzwerktechnik auskennen. 

Bitte keine Verweise an die "Hotline" - das macht auf Grund des extremen Wissensdefizit der Hotlinemitarbeiter im Bereich Netzwerk keinen Sinn. Und ich habe es versucht 🙂 

 

Folgende Ausgangssituation.

Ich habe zwei SkyQ-Receiver.
Beide sind via RJ45 mit meinem Netzwerk verbunden. Bei beiden ist WLAN deaktiviert. 

Mein Netzwerk ist aus Sicherheitsgründen in mehrere VLANs unterteilt. Unter anderem auch in ein "IoT-VLAN". 

Also ein separates Netzwerk für alle IoT Geräte, damit diese - selbst im Falle einer Kompromittierung - keinen Zugriff auf meinen Server oder meine PCs/Macs erhalten. 
In dem IoT-VLAN befinden sich somit, neben den zwei SkyQ-Receivern, noch folgende Geräte
2x Apple TVs
2x SmartTVs

1x Playstation 4

1x Thermomix

1x Pioneer AVR

1x Harmony Hub

1x Netatmo Relay

5x SmartHome - Geräte

ALLE Geräte haben - erwartungsgemäß - Internetzugriff. Funktionieren tadellos.

Sie sind auch von meinem Haupt-VLAN erreichbar, da ich ja z.B. von meinem Mac auf den Apple-TV streame oder auch "Playstation Remote" nutze. Die Kommunikation ist also sichergestellt, ABER - und das ist auch mein Problem - scheinen die SkyQ-Receiver nicht in der Lage zu sein, in dieser Konstellation zu funktionieren.

Beide bestätigen mir in den Einstellungen (siehe Fotos) zwar, dass sie sowohl eine Verbindung zum Router, als auch zum Internet haben, aber wenn ich dann auf HOME, SERIEN, FILME, STORE oder APPs gehe, bekomme ich die Fehlermeldung [15024 bzw. 15022], dass ich angeblich nicht mit dem Internet verbunden bin. 🙈


Das hier ein Softwareproblem der Receiver vorlegen muss, bestätigt - neben der Tatsache das 14 andere Geräte tadellos funktionieren - auch das folgende "Wunder".
Denn obwohl der SkyQ Receiver angeblich keine Verbindung zum Internet hat, empfängt er hervorragend meine vom Handy (über LTE - nicht im WLAN) ausgelösten Aufnahmen und startet sofort mit der Aufnahme. 
Eine Auswertung des Netzwerktraffics (WAN In-/Outgoing - siehe Screenshot) zeigt auch, dass er eigentlich eine Verbindung hat - sonst könnte er auch kein Traffic verursachen. 

 

Zusätzlich (und das habe ich bei meiner stundenlangen Google-Recherche auch schon gelesen) finden die SkyGo-Apps (auf iPhone und iPad - im Haupt-VLAN) nicht die Receiver (im IoT-VLAN). 
Erst wenn ich mit meinem iPhone/iPad ins IoT-VLAN wechsle (was natürlich nicht Sinn der Sache ist) werden auch die Receiver gefunden. 

Langer Rede kurzer Sinn:
Kann es sein, dass die SkyQ-Receiver nicht in der Lage sind, Teil eines VLANs zu sein? 

Ich war schon verwundert, dass der Receiver das erste und einzige Gerät ist, was ich in über 20 Jahren IT-Technik kennengelernt habe, was nicht in der Lage ist, einen sekundären DNS-Server zu hinterlegen. 

Gibt es hier "Interne" die mitlesen und das Problem mal an die Technik weiterleiten können - also an richtige Techniker? 
Wie gesagt macht eine Diskussion mit den Hotline-Kollegen keinen Sinn, da die schon bei den Wörtern DNS oder VLAN aussteigen. 

 

Fürs Protokoll: 
- Ich habe (auch wenn es unfug ist) alle Netzwerkkomponenten neu gestartet
- Ich habe bei beiden Receivern die Netzwerkeinstellungen zurückgesetzt

- Ich habe bei beiden Receivern sowohl via DHCP als auch via manuell die IP-/Netzwerkdaten hinterlegt

- Ich habe bei beiden Receivern den DNS Server gewechsel (Pi-Hole + 1.1.1.1 / 1.0.0.1)

- Ich habe beide Receiver komplett auf Werkseinstellungen zurück gesetzt. 

 

Ich hoffe irgendwer kann mir hier helfen - und wenn es nur die Weiterleitung an einen internen "Techniker" ist. 

Vielen Dank und einen schönen Wochenstart. 

 

Alle Antworten
Antworten
tom75
Castingleiter
Posts: 2,421
Post 2 von 16
9.463 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Also ohne es jetzt wirklich genau zu wissen, vermute ich, dass die bei Sky zählen, wie viele "hops" die Daten-Pakete machen. Wenn der "Hop Count" eine bestimmte Anzahl überschreitet werden sie die Verbindung nicht zulassen. Bei Sky sind sie Erfahrungsgemäß etwas paranoid, was Content-Schutz und VPN angeht ..... 

Maddeen
Tiertrainer
Posts: 15
Post 3 von 16
9.455 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Ahh - aus dem Blickwinkel habe ich es noch nicht betrachtet. Kann aber gut sein - wenn man sonst leider kaum was ordentlich hin bekommt - aber "Sicherheit" über alle Maßen - das können se 😞

Ich teste gleich mal, ob es über das IoT-VLAN tatsächlich mehr Hops zu Sky sind, als aus meinem normalen VLAN. 

 

Bin mal gespannt, ob was kommt bzw. sich ein Mitarbeiter einschaltet. 

 

Maddeen
Tiertrainer
Posts: 15
Post 4 von 16
9.458 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Gerade mal verglichen - exakt gleiche Anzahl an Hops - siehe Screen

Der Weg ist sogar komplett identisch

 

1. Hop zum Gateway (hier natürlich einmal 10.20.0.254 [Standard] und 10.30.0.254 [IoT-VLAN])

2. Hop zum ISP (62.155.241.133)

3. Hop zum ISP (62.154.43.174)

4. Hop zu "keine Ahnung" (80.157.128.58)

5. Hop zum Ziel Sky.de auf einem Akamai-Server (104.107.213.45)

tom75
Castingleiter
Posts: 2,421
Post 5 von 16
9.447 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Im Haupt-VLAN funktioniert der Receiver?

Maddeen
Tiertrainer
Posts: 15
Post 6 von 16
9.430 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

@tom75 - hab ich gerade gemacht. Und jetzt weiß ich auch, wo der Sky Receiver ein Problem hat.

Er kommt offensichtlich nicht mit getaggten Ports zu recht. 

 

Ausgangssituation war ja --> Port getagged auf IoT-VLAN --> kein Internet

Dann habe ich, wie du vorgeschlagen hast --> Port getagged auf Home-VLAN --> auch kein Internet

Und dann dachte ich mir, mal gucken was er ohne tagging macht --> Tadaaa - Receiver hat sofort Internet. 

Allerdings ist er dann in meinem Management-VLAN --> Absolutes NoGo!!! 

 

Das Problem ist aber, dass ich ihn jetzt natürlich nicht in mein IoT-VLAN bekomme. 

Sobald ich den Port wieder tagge ist das Internet sofort weg. 

 

Eigentlich würde ich gerne jetzt noch den Sky-Kollegen sagen, wie das "Feature" heißt, woran es fehlt - aber so tief bin ich jetzt auch nicht in der Materie. Es kann aber auch nichts dramatisches sein, weil selbst das billigste China-Gerät mit meinen VLANs arbeiten kann. 

 

Und natürlich bleibt die größte Herausforderung --> nämlichen einen Sky Mitarbeiter zu finden der das hier liest, versteht und es dann noch einem Techniker zur Verfügung stellt. 

 

Ich befürchte, dass ich ohne eine Lösung leider kündigen werde - ich akzeptiere nämlich kein Sicherheitsrisiko auf Grund von unfähiger Software. Das ist ansich ja schon ein Grund, der für eine Netztrennung spricht 🙂

tom75
Castingleiter
Posts: 2,421
Post 7 von 16
9.400 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

@Maddeen 

Ich befürchte das es von Sky keine Lösung geben wird, die deinen Sicherheitsansprüchen genügt ...

 

Was du noch versuchen könntest, ist den Sky-Receiver in eine extra DMZ einzubinden über die er Zugang zum Internet hat, aber keinen allgemeinen Zugriff auf dein Netzwerk. Deinem IoT-VLAN kannst du von "innen" Zugriff auf die DMZ geben, und wenn nötig kannst du auch deinem Receiver "erlauben" über einen bestimmten Port mit einer festen IP-Adresse mit Geräten im IoT-VLAN zu kommunizieren.

Maddeen
Tiertrainer
Posts: 15
Post 8 von 16
9.346 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Jep, dass befürchte ich auch - aber das macht mir dann die Entscheidung einfacher. 

Ich sehe halt auch nicht ein, für ein einziges Gerät (von über 30!!!) eine Sonderlösung zu bauen, weil es zu blöd ist, eine Standardfunktion von Netzwerken zu unterstützen.

Selbst ein Thermomix, dessen Grundidee sicherlich x-fach weniger mit Netzwerk zu tun hat, als ein Receiver, ist in der Lage damit umzugehen. 

Das ist schon traurig ... quasi von einem Küchengerät geschlagen - ich würde vor Schande im Boden versinken. 

 

Aber gut - also der nächste Minuspunkte auf der Sky-Seite. 

  • Erst das "Mirroring/Spiegel" Verbot von mobilen Geräten an große Monitore
  • Dann die fehlende Unterstützung von Sky Go auf einem AppleTV (ohne SkyQ Receiver im LAN)
  • Dann die Beschränkung von Geräten pro SkyGo-Account mit unverschämten Fristen
  • Dann der Verlust von CL und EL-Rechten.
  • Dann der Verlust von Fr./So. Spielen der BL
  • Und jetzt noch die technische Bankrotterklärung mit dem VLAN
    • Neben dem Thema, dass man nur einen DNS Server angeben kann (Wo gibts bitte sowas?!?)

That's the way the cookie crumbles - bin draußen, wie ein Dixi-Klo. 

Dir trotzdem vielen Dank und einen schönen Abend. 

 

 

 

 

 

christian_mickn
Maskenbildner
Posts: 304
Post 9 von 16
9.318 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Hallo @Maddeen  und @tom75 ,

 

ich weiß nicht, ob mein Vorschlag hilfreich ist oder der Fehler, den ich bei mir festgestellt habe, in die gleiche Richtung geht.

Man liest hier und hört an der Hotline immer wieder, dass der Sky Q-Receiver Probleme mit dem 5 GHz-WLAN-Netz haben soll. Ich kann das bezeugen:

Bei mir zeigt sich das z.B. wenn ich die Playstation 4 (Chassis CUH 1004A) im WLAN betreibe und währenddessen der Sky Q-Receiver eingeschaltet ist. 

Kurios: Obwohl es sich bei der PS 4 um das Ur-Modell von 2013 handelt und sie nur 2,4 GHz-WLAN beherrscht, stört der Sky Q-Receiver die PS4 (keine Downloads möglich und Verbindungsfehler).

Auch beim Sky-Q zeigen sich dann ähnliche Fehlerbilder wie @Maddeen sie beschrieben hat.

Schon mal probiert auf 2,4 GHz auf dem Sky Q zu gehen?

Welche PS 4 hast du?

Maddeen
Tiertrainer
Posts: 15
Post 10 von 16
9.301 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Ich habe nur die wirklich zwingend notwendigen Geräte im WLAN. Habe hunderte Meter Kabel verlegt - sprich der Receiver ist per Kabel am Netz. WLAN habe ich abgeschaltet. 

Übrigens genau aus solchen Gründen, wie bei dir.

Zu viele WLAN-Geräte sind nicht gut - gerade auch, wenn man kein aktuellen WLAN-AP hat der MuMiMo usw. unterstützt. Sobald ein Gerät einen Stecker hat, gibt es auch ein Kabel 🙂 

christian_mickn
Maskenbildner
Posts: 304
Post 11 von 16
9.311 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

@Maddeen 

 

Ich bin genau deiner Meinung. Ich bin einfach ein Freund von kabelgebundenen Verbindungen. Habe zum Glück auch im ganzen Haus in den Wänden LAN-Kablel verlegt.

Bei dieser Instabilität eine Überlegung wert, auf Bewährtes umzusteigen 😀

Eigentlich schade.....Wenn ich an die guten alten D-Box-Zeiten denke, könnte ich weinen, wenn ich die heutige Technik anschaue, die Sky anbietet. 😥

Maddeen
Tiertrainer
Posts: 15
Post 12 von 16
9.202 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Ohne es genau zu wissen, wird aber auch hier der Schuldige vermutlich "der Entwickler" sein - also so, wie man es oft bei OEM Hardware mit individueller Software kennt. 

Humax ist als Hersteller eigentlich eine Top-Marke - hardwaretechnisch ist das Gerät auch gut aufgestellt. Aber wenn dann die (offensichtlich) eher nicht so technisch begabten Sky-Entwickler dafür ein OS schreiben müssen, kommt sowas bei raus. Wie gesagt - zeig mir EIN Gerät - egal aus welchem Bereich, was mit dem Internet verbunden wird, aber nur EINEN DNS-Server erlaubt. Ich glaube das hat selbst Microsoft bei Windows 95 schon richtig gemacht. DNS ist ein SPOC - ergo gibt es mindesten 2 - bei mir daheim (Unifi) sogar VIER.

 

Das ist wie damals bei der Telekom mit dem W701V Router -- die Hardware war von AVM und einfach genial. Aber mit dem gebrandeten OS der Telekom ist aus dem Porsche ein Dacia geworden. Nicht umsonst gab es nachher (und auch jetzt noch) Tools, die die originale AVM Firmware/OS wieder auf die Geräte bügeln. 

AchimK
Geräuschemacher
Posts: 5
Post 13 von 16
8.897 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

hallo,

mein sky receiver hat keinen 2.4 GHz WiFi Empfangskanal, nur 5 Ghz (Stand November 2020).

Mein Router (FritzBox 7590) switch je nach Bedarf automatisch zwischen 2.4 und 5.Ghz BAndbreite.

Ich habe dann eine separate Wifi Connection fuer 2.4 und fuer 5 Ghz eingereichtet, zB. router 24 und router5.

Nach der Verbindung der sky q box mit WiFi connection router5 hatte ich dann Internet.

Gruss Achim

Maddeen
Tiertrainer
Posts: 15
Post 14 von 16
8.677 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

So - ich glaube ich habe die Lösung. 

Sofern die Receiver morgen auch noch funktionieren, ist das die Lösung.

 

Abgesehen von den Port Forwards (3700, 5320, 5340, 5360) muss man den Receivern auch Zugriff auf das Gateway geben. 

Warum man das machen muss, erschließt sich mir nicht, da bei mir nur 2 Geräte Zugriff auf das Gateway haben - und alle anderen +28 nicht. Aber alle Geräte funktionieren mit dieser Konfiguration tadellos!! 

 

Welcher Port / Protokoll entscheidend ist, kann ich noch nicht sagen, da ich aktuell nur eine "alle Ports" Freigabe gesetzt habe. 

 

Ich werde morgen aber mal gucken, ob ggf. nur ICMP (Ping) ausreicht oder ob noch mehr gebraucht wird.

 

AN SKY

Freunde der Sonne - das ist ein essentielles Security Problem.

Kein Gerät benötigt für eine funktionierende Internetverbindung Zugriff auf das Gateway!!

So kann nämlich jeder Hacker über ein kompromittiertes Gerät (was meistens so vernachlässigte Geräte wie IoT-Zeugs und eure Receiver sind) einfach auf das Gateway zugreifen und im Zweifel mein ganzes Netzwerk (VLAN übergreifend) kompromittieren/analysieren. 

 

 

ckd
Tiertrainer
Posts: 21
Post 15 von 16
5.156 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Nach zwei Monaten Fehlersuche kann ich bestätigen: es liegt am PING / ICMP8 Protokoll. Kriegt die Sky-Box keine Antwort vom Gateway, kommt dieser hässliche Fehler 1502x, auch wenn alles andere funktioniert (Apps, On-Demand Inhalte aus der Historie etc.).

 

Siehe: https://community.sky.de/t5/Receiver/Fehler-15020/td-p/353943/page/3

 

In Hoffnung, dass dieser Beitrag jedem hilft, der ebenfalls dieses Problem hat.

Tueddelclick
Special Effects
Posts: 9
Post 16 von 16
994 Ansichten

Betreff: SkyQ im Internet und eigentlich doch nicht [15024] [15022]

Über drei Jahre später gibt es inzwischen eine Einstellung an der Fritzbox, die das Problem mit den Ports löst. (Zumindest für mich)

in der Fritzbox für den Sky Q Receiver (nicht den Client) das Setting "Selbstständige Portfreigaben für dieses Gerät erlauben" anschalten. Hat bei mir sofort funktioniert. 
Sky Q App auf Apple TV über Wlan kommt jetzt auch in die Mediathek und hat keine Netzwerkfehler mehr. 

Gruß

Olli

Antworten